Skip to main content

Topic: Link 2000  (Read 244 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • bbeane
  • [*][*][*][*][*]
Link 2000
It appears my link 2000 is locked up, it doesn't appear to be controlling any thing and the green light is under amps but volts are showing. Anyone have any sperance with them?

Re: Link 2000
Reply #1
You have to do a hard reset.  Refer to the owner's manual, but basically you have to remove power to the unit for a set period of time.

  • bbeane
  • [*][*][*][*][*]
Re: Link 2000
Reply #2
Thanks Amos, I plan on that in the morning.

  • bbeane
  • [*][*][*][*][*]
Re: Link 2000
Reply #3
Any one happen to know where the fuse/CB is for the link 2000 wireing diagrams don't seem to show it.

Re: Link 2000
Reply #4
Bruce,
I think (long time ago) I put mine buy the shunt by the coach batteries.

  • bbeane
  • [*][*][*][*][*]
Re: Link 2000
Reply #5
Thanks mine came new with the coach.So FT wired it with their numbered white wire, I can't see the number on the wire.
The hard reset took care of the problem. Just want to find the circuit for the next time. Better than removing the grounds.

Re: Link 2000
Reply #6
Bruce,

I'm late to the party but this may help in the future.

The feed to the Link 2000 should come off one of the non-self resetting breakers that are hid behind the white cover in the basement on your age coach. IIRC it is the 2nd or 3rd one...

Guests must Login or Register to view full posts.

  • bbeane
  • [*][*][*][*][*]
Re: Link 2000
Reply #7
Thanks Mike, already looked behind the link no fuse. I'll see which one it is down stairs

  • bbeane
  • [*][*][*][*][*]
Re: Link 2000
Reply #8
Found it Mike 3rd one up on the left 10 amp. Thanks.